----- Original Message ----- From: "Allen Schmidt Sr." <[EMAIL PROTECTED]>
To: <zope@zope.org>
Sent: Wednesday, August 16, 2006 11:07 AM
Subject: Re: [Zope] Parameter generating an exception? (also recatalogingissue)



I will bounce this out since I tried this recently while testing an upgrade.

We are on 2.7.5 and our 200K+ news articles are all ZClass objects and are cataloged. We setup a 2.8.6 instance and made sure all Products, Extension, etc. were the same. Copied our Data.fs and brought up the instance. I could browse around the site fine until I did anything that utilized the catalog to look up the news articles. Did not find anything. I could navigate directly to an article and it displayed fine.

I then tried to clear the catalog and find objects of the zclass type....it found nothing.

This has been a rather large stumbling block to us upgrading.

Any ideas? No rush...no emergency ... but would like to upgrade sometime soon hopefully.

Something changed in ZCatalog indexes between Zope 2.7 and 2.8, and you may be running in to a related problem. Google for 'manage_convertIndexes' (you can also read the CHANGES.txt for Zope 2.8)

Jonathan
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to