Hi;
I'm reading the Plone book. It states that for Zope 2.7 (I have 2.78) ZEO is built in by default but must be instantiated thus:


cd /opt/Zope-2/7/bin
./mkzeoinstance /var/zeo

or some such code. So I tried this:

cd /usr/local/zope/278/bin
./mkzeoinstance.py ../../instance2/var/zeo

where 278 is my installation, instance2 is a Zope instance (I have 3), and mkzeoinstance.py is the command that works (mkzeoinstance by itself doesn't print anything to screen other than a command failed message). The Plone book then states that I must move Data.fs into the new /zeo/var dir, which I did. Everything seems to go well. If I start Zope using runzope I get this output at the tail end:

------
2006-09-02T13:15:35 INFO(0) Zope Ready to handle requests

However, if I try to log into the ZMI my passwords don't work. I even tried creating an emergencyuser and that didn't work, either. What to do? Also, should I move these other files into the new zeo/var dir?

Data.fs.index Data.fs.lock Data.fs.old Data.fs.tmp I tried that, also, with negative results, but it seems to me that if I'm moving Data.fs I should move these others as well.
TIA,
beno
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to