----- Original Message ----- From: "beno" <[EMAIL PROTECTED]>
To: <zope@zope.org>
Sent: Saturday, September 02, 2006 9:24 AM
Subject: [Zope] ZEO Problem

I'm reading the Plone book. It states that for Zope 2.7 (I have 2.78) ZEO is built in by default but must be instantiated thus:

cd /opt/Zope-2/7/bin
./mkzeoinstance /var/zeo

or some such code. So I tried this:

cd /usr/local/zope/278/bin
./mkzeoinstance.py ../../instance2/var/zeo

where 278 is my installation, instance2 is a Zope instance (I have 3), and mkzeoinstance.py is the command that works (mkzeoinstance by itself doesn't print anything to screen other than a command failed message). The Plone book then states that I must move Data.fs into the new /zeo/var dir, which I did. Everything seems to go well. If I start Zope using runzope I get this output at the tail end:

2006-09-02T13:15:35 INFO(0) Zope Ready to handle requests

In your .../log/events.log file you should see some zeo connection activity, like:

2006-09-02T08:11:17 INFO Zope Ready to handle requests
2006-09-02T08:11:44 INFO ZEO.ClientStorage (3196) ClientStorage (pid=3196) created RW/normal for storage: '1'
2006-09-02T08:11:44 INFO ZEO.cache created temporary cache file '<fdopen>'
2006-09-02T08:11:44 INFO ZEO.ClientStorage (3196) Testing connection <ManagedClientConnection ('', 8100)>
2006-09-02T08:11:44 INFO ZEO.zrpc.Connection(C) ( received handshake 'Z303'
2006-09-02T08:11:44 INFO ZEO.ClientStorage (3196) Server authentication protocol None
2006-09-02T08:11:44 INFO ZEO.ClientStorage (3196) Connected to storage: ('sparrow.conetra.com', 8100)
2006-09-02T08:11:44 INFO ZEO.ClientStorage (3196) Verifying cache
2006-09-02T08:11:44 INFO ZEO.ClientStorage (3196) Waiting for cache verification to finish
2006-09-02T08:11:44 INFO ZEO.ClientStorage (3196) Waiting for cache verification to finish
2006-09-02T08:11:44 INFO ZEO.ClientStorage (3196) endVerify finishing
2006-09-02T08:11:44 INFO ZEO.ClientStorage (3196) endVerify finished

This will tell you that your zeo client is connected to the zeo server

However, if I try to log into the ZMI my passwords don't work. I even tried creating an emergencyuser and that didn't work, either. What to do? Also, should I move these other files into the new zeo/var dir?

Data.fs.index Data.fs.lock Data.fs.old Data.fs.tmp

All you need is Data.fs.

Data.fs.index will be recreated if it is not found when zope starts
Data.fs.old is created when you pack your zodb
You can safely ignore the .lock and .tmp files (they are created by Zope as needed)


Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to