Hi

I have a problem with a site running on Zope 2.7.5.

After a restart the site serves request happily for a while and then hangs, meaning:

- The server processes are still alive (I can see them with ps)
- New attempts of page views do not show in the Z2.log
- Browser just reports time out (not that the site is not available)
- DeadlockDebugger does not respond either

There is no recognisable pattern looking at the last requests in the Z2.log before the site hangs. The last requests are mostly just view requests of pages, which display fine after a restart.

I've tried packing the ZODB (which worked fine, but did not resolve the issue). I've run the fsrecover.py, but that didn't seem to find anything.

I have moved the Data.fs to another machine where I have a Zope 2.7.8 and tried some tests there, but again couldn't find anything pointing towards a possible source of the problem.

I have now enabled the event.log and got this entry on the last "hangup":

2006-09-06T19:44:34 ERROR(200) ZServer uncaptured python exception, closing channel <ZServer.HTTPServer.zhttp_channel connected 212.96.102.29:3207 at 0x9c0326c channel#: 149 requests:> (exceptions.ValueError:HTTP headers invalid (too long) (got: 8760 bytes, allowed 8192 bytes [/sw1/packages/python235/lib/python2.3/ asyncore.py|read|69] [/sw1/packages/python235/lib/python2.3/ asyncore.py|handle_read_event|390] [/sw1/packages/python235/lib/ python2.3/asynchat.py|handle_read|148] [/sw0/sbzope_3_2/lib/python/ ZServer/HTTPServer.py|collect_incoming_data|378])

But I don't really understand what it means.

Any help or suggestions welcomed!

Thanks

DR

_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to