David wrote:
- Browser just reports time out (not that the site is not available)

Too many negatives inside your brackets, please clarify...

- DeadlockDebugger does not respond either

I find that hard to believe...

I've tried packing the ZODB (which worked fine, but did not resolve the issue).

No, can't see that helping here.

I've run the fsrecover.py, but that didn't seem to find anything.

Again, irrelevent here.

I have now enabled the event.log

?! You should ALWAYS be writing an event log...

and got this entry on the last "hangup":

2006-09-06T19:44:34 ERROR(200) ZServer uncaptured python exception, closing channel <ZServer.HTTPServer.zhttp_channel connected at 0x9c0326c channel#: 149 requests:> (exceptions.ValueError:HTTP headers invalid (too long) (got: 8760 bytes, allowed 8192 bytes [/sw1/packages/python235/lib/python2.3/asyncore.py|read|69] [/sw1/packages/python235/lib/python2.3/asyncore.py|handle_read_event|390] [/sw1/packages/python235/lib/python2.3/asynchat.py|handle_read|148] [/sw0/sbzope_3_2/lib/python/ZServer/HTTPServer.py|collect_incoming_data|378])

Ah, so you're exposing Zope to the big wide internet without a protective proxy like Apache in from?


Read the error message. People are trying to hack your server. Zope tries to prevent against it, but I'd still stick a defensive proxying configuration of Apache in front and see if the problem goes away..


Simplistix - Content Management, Zope & Python Consulting
           - http://www.simplistix.co.uk

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to