Hello everybody,

a few days we migrated from Zope 2.7.0 to Zope 2.9.0 (ok, the
up-to-date version is 2.9.4, but we had this version compiled some
time ago and now finaly migrated the DB), and now we are experiencing
problems with our user management. To migrate the DB I just exported
everything from the old zope instance and importet it again into the
new Zope Instance, Products and Extensions were just copied from the
old to the new instance. Everything, except user management, works
quite fine, only the Localizer-Product had to be replaced by a newer

We have a subfolder 'z' where we have an exUserFolder that imports
users from a MySQL DB, below this subfolder 'z' there is anotherfolder
'y' (t.m. <root>/z/y), and the users in the exUserFolder in 'z' have
the rights to access the folder 'y'. When I now give an additional
right to 'Anonymous' within folder 'y', folder 'y' cannot be accessed
anymore by the users defined in the exUserFolder.

Another problem is that creating User Folders and users within these
folders does not work properly any more, t.m. such folders and users
can be created but the particular user cannot login although they
should have proper permissions.

I have no clue by what these problems are caused. I would be very
grateful if someone could give me a hint. Could this problem be
related to a wrong apache configuration? Is it possible that the DB
got messed up when I imported it into 2.9.0? Or may incompatibilities
of a special Product with 2.9.0 cause these troubles?

Thanks in advance, Fabian
Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to