Stefan H. Holek, on 2006-10-05:
> Maurits, you seem to be working as root, which is the root of all  
> evil (pun intended). Don't do that, ever. The permission issues you  
> reported also only crop up if the tarball is extracted while root.  
> Don't do that!

Actually, I don't. :)

Extract the original tar ball, do a 'find -perm 600' and you'll see
lots of files that have the wrong permissions.  The new tar is good in
that respect.  But let's look at the 'root' cause:

~/download $ tar xzf Zope-2.10.0-final.tgz # That's the current one.
~/download $ cd Zope-2.10.0-final/
~/download/Zope-2.10.0-final $ find -user root
~/download/Zope-2.10.0-final $ ./configure
(snip the usual output)
~/download/Zope-2.10.0-final $ make
(snip the usual output)
[EMAIL PROTECTED]:~/download/Zope-2.10.0-final $ make install
"/usr/bin/python" "/home/maurits/download/Zope-2.10.0-final/setup.py" \
            build 
--build-base="/home/maurits/download/Zope-2.10.0-final/build-base/python-2.4" 
--build-lib="/home/maurits/download/Zope-2.10.0-final/build-base/python-2.4/build-lib"
 
--build-scripts="/home/maurits/download/Zope-2.10.0-final/build-base/python-2.4/build-scripts"
 
--build-temp="/home/maurits/download/Zope-2.10.0-final/build-base/python-2.4/build-temp"
(snip)
running build_ext
creating zope.proxy
copying zope/proxy/proxy.h -> zope.proxy
copying /home/maurits/download/Zope-2.10.0-final/lib/python/version.txt -> 
/home/maurits/download/Zope-2.10.0-final/build-base/python-2.4/build-lib
running install_lib
creating /opt/Zope-2.10
error: could not create '/opt/Zope-2.10': Permission denied
make: *** [install] Error 1

That's logical, as I don't have the permissions to install anything in
/opt as normal user.

[EMAIL PROTECTED]:~/download/Zope-2.10.0-final $ find -user root
[EMAIL PROTECTED]:~/download/Zope-2.10.0-final $ sudo make install
(snip)
Zope binaries installed successfully.
Now run '/opt/Zope-2.10/bin/mkzopeinstance.py'
[EMAIL PROTECTED]:~/download/Zope-2.10.0-final $ find -user root
./lib/python/zope.proxy
./lib/python/zope.proxy/proxy.h
./build-base/python-2.4/build-lib/version.txt

Bingo, there is your error.  Well, like I said, that's not a big deal,
but still...

-- 
Maurits van Rees | http://maurits.vanrees.org/ [NL]
            Work | http://zestsoftware.nl/
       GnuPG key | http://maurits.vanrees.org/var/gpgkey.asc
"Do only what only you can do." --- Edsger Wybe Dijkstra

_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to