Tres Seaver wrote:
Chris Withers wrote:
ouch... I'd imagine Zope is vulnerable to this?

What source version(s) of python have these problems fixed?

I think the issue only surfaces if you compile Python for UCS4, which
the desktop-centric versions shipped by the distros do.  If you build
Python using the default config, it uses UCS2 (which is a better choice
for long-running appservers, anyway).

I just verified this by running the example code from the SF bug[1]:  it
aborts when run with Ubuntu's own python2.4, but not with the one I run
Zope with.

Right. Same here. System python barfs on the 2nd example, source-compiled python doesn't for me...

Python 2.4.4 will have this fix, when released.

[1]
http://sourceforge.net/tracker/index.php?func=detail&aid=1541585&group_id=5470&atid=305470

I do think it's worth stressing that if you're running Zope, you should at least check that the two examples don't barf on your machine.

I'm sure there are lots of people out there using system builds of python, and it looks like at least the stable debian and ubuntu builds are vulnerable...

Chris

--
Simplistix - Content Management, Zope & Python Consulting
           - http://www.simplistix.co.uk
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to