So... We decided to move from Zope 2.6.4 to something newer (currently
targetting Zope 2.10.0). I immediately found that none of our
PageTemplates work we get an error on

PageTemplates/Expressions.py line 92 that call_with_ns is not defined.

  ob = call_with_ns(ob, ns, 2)

Changing it as follows fixes the problem, I think this is a bug.

  ob = ZRPythonExpr.call_with_ns(ob, ns, 2)

Next... we have lots of PageTemplates which raise the following exception:

  Module zope.pagetemplate.pagetemplate, line 118, in pt_render
  Module StringIO, line 271, in getvalue
UnicodeDecodeError: 'ascii' codec can't decode byte 0xb9 in position 93:
ordinal not in range(128)

I suspect there are non-ascii characters in the file, but I'm not sure
how to fix this, or how I would know what to replace it with. Is there a
way to turn off Unicode support?

Any other issues I might run into during this upgrade? Should we move to
an older version (2.8? 2.9?) first and then onto 2.10?

Thanks,
-- 
Brian Brinegar
Web Systems Developer
Engineering Computer Network
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to