David H wrote:

Marek SzczypiƄski wrote:

Here is the traceback. Looks like problem with matplotlib it self,
doesn't it? Did anyone have the same problems?
Thanks for any help.


Traceback (innermost last):
 Module ZPublisher.Publish, line 115, in publish
 Module ZPublisher.mapply, line 88, in mapply
 Module ZPublisher.Publish, line 41, in call_object
 Module Products.ExternalMethod.ExternalMethod, line 59, in
 Module Products.ExternalMethod.ExternalMethod, line 111, in __init__
 Module Products.ExternalMethod.ExternalMethod, line 134, in manage_edit
 Module Products.ExternalMethod.ExternalMethod, line 141, in getFunction
 Module App.Extensions, line 148, in getObject
  - __traceback_info__:
('/var/lib/zope/zope-markacy/Extensions/mpl.py', 'mpl')
 Module /var/lib/zope/zope-markacy/Extensions/mpl.py, line 1, in ?
 Module None, line 1011, in ?
 Module None, line 968, in rc_params
 Module None, line 914, in matplotlib_fname
 Module None, line 273, in wrapper
 Module None, line 324, in _get_configdir
RuntimeError: '/' is not a writable dir; you must set environment
variable HOME to be a writable dir
Hi Marek,
Never heard of matplotlib. But your traceback is saying that the product is trying to write to root - without sufficient permission. I'd look at the source (see _get_configdir) and see if its reading some sort of config file or maybe its parsing the enviromental var HOME.. You probably can modify that. Anyway, writing to "/" doesnt seem to be a good idea in any case.

You have set variable "HOME"?
David H


I gave bad advise.  Don't mess with (set) your HOME enviro var.


Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to