You could 'bite the bullet' and replace your ZClasses with standard python 
classes (create a very simple 'product' that just contains the class 
definitions). I am doing this for an application that needs to be running for 
several years to come, and have decided that the best course for long term 
sustainability is to remove the ZClasses (a serious pita, but worth it in the 
long run as it simplifies future zope updates).


Jonathan

  ----- Original Message ----- 
  From: Allen Huang 
  To: Zope 
  Sent: Thursday, December 28, 2006 8:39 AM
  Subject: Re: [Zope] usering module problem on zope 2.8.8


  I'm sorry Andreas. But I still don't see any solution to this problem. Do you 
have a solution? or there is no solution at all?


  ----- Original Message ----
  From: Andreas Jung <[EMAIL PROTECTED]>
  To: Allen Huang <[EMAIL PROTECTED]>; Zope <zope@zope.org>
  Sent: Thursday, December 28, 2006 3:33:44 PM
  Subject: Re: [Zope] usering module problem on zope 2.8.8


  -----BEGIN PGP SIGNED MESSAGE-----
  Hash: SHA1



  - --On 27. Dezember 2006 16:12:23 -0800 Allen Huang <[EMAIL PROTECTED]> wrote:

  > I basicly copy what I have from 2.8 to 2.9
  > its the same problem with the self generated python constructor and the
  > self constructor that I made both worked in 2.8 but won't for 2.9
  >
  > my constructor look like this using
  >
  > <dtml-with "shpTypeClass.createInObjectManager(REQUEST['id'], REQUEST)">
  >  <dtml-call
  > "propertysheets.shpTypePoint_desc.manage_editProperties(REQUEST)">
  >  <dtml-if NoRedir>
  >   <dtml-return name="this">
  >  <dtml-else>
  >   <dtml-if DestinationURL>
  >    <dtml-call "RESPONSE.redirect(DestinationURL+'/manage_workspace')">
  >   <dtml-else>
  >    <dtml-call "RESPONSE.redirect(URL2+'/manage_workspace')">
  >   </dtml-if>
  >  </dtml-if>
  > </dtml-with>
  >
  > the error is
  >
  > Time2006/12/27 19:48:33.523 GMT+8
  > User Name (User Id)admin (admin)
  > Request
  > URLhttp://localhost/test/manage_addProduct/shpProcessing/shpTypeClass_fac
  > tory/shpTypeClass_add Exception TypeTypeError
  > Exception Valuedefault __new__ takes no parameters
  >
  > Traceback (innermost last):
  > Module ZPublisher.Publish, line 121, in publish
  > Module Zope2.App.startup, line 240, in commit
  > Module transaction._manager, line 96, in commit
  > Module transaction._transaction, line 380, in commit
  > Module transaction._transaction, line 378, in commit
  > Module transaction._transaction, line 433, in _commitResources
  > Module ZODB.Connection, line 484, in commit
  > Module ZODB.Connection, line 526, in _commit
  > Module ZODB.Connection, line 553, in _store_objects
  > Module ZODB.serialize, line 407, in serialize
  > Module ZODB.serialize, line 416, in _dump
  > Module copy_reg, line 70, in _reduce_ex
  > TypeError: default __new__ takes no parameters
  >
  > what is the problem??

  <http://www.zope.org/Collectors/Zope/2005>

  - -aj
  -----BEGIN PGP SIGNATURE-----
  Version: GnuPG v1.4.6 (Darwin)

  iD8DBQFFk3NZCJIWIbr9KYwRAgXnAKDc609jQzO/7J1DFWVsAUAwruTSJgCgmJuO
  c00q/FmZLZlfb1wkpobNtuI=
  =75fR
  -----END PGP SIGNATURE-----



  __________________________________________________
  Do You Yahoo!?
  Tired of spam? Yahoo! Mail has the best spam protection around 
  http://mail.yahoo.com 


------------------------------------------------------------------------------


  _______________________________________________
  Zope maillist  -  Zope@zope.org
  http://mail.zope.org/mailman/listinfo/zope
  **   No cross posts or HTML encoding!  **
  (Related lists - 
   http://mail.zope.org/mailman/listinfo/zope-announce
   http://mail.zope.org/mailman/listinfo/zope-dev )
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to