> I just checked an older version of python (2.3.4) on my linux server
> and the 'from datetime import datetime' command worked just fine, so
> your 2.3.5 version should have 'datetime'.  All i can think of is that
> your python installation is pooched.  Can you 'uninstall' python, and
> then download/re-install a fresh version?
>
Zope for Windows has its own Python included and it is installed
by default at c:\Program files\Zope....\bin\python.exe

I've just tried on my vmware Windows installation to download
Zope 2.8.8 final from zope.org and install it.
It just works, even without 'work as service' option.
from datetime import datetime works as well.

Python 2.3.5 (#62, Feb  8 2005, 16:23:02) [MSC v.1200 32 bit (Intel)] on
win32
Type "help", "copyright", "credits" or "license" for more information.
>>> from datetime import datetime
>>> exit
'Use Ctrl-Z plus Return to exit.'
>>> ^Z

I'm not sure why it fails on your system. Try googling for datetime
problems.

-- 
Maciej Wisniowski
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to