I've installed Plone 2.5.2 by the new intaller on a linux box. It came
with zope 2.9.6, Python 2.4.4. But I can not make ZMySQLDA installed on
zope. Can anyone help me?

I installed MySQL-python-1.2.2 with the same version of python for plone.
sudo /opt/Plone2.5.2/Python2.4.4/bin/python setup.py build
sudo /opt/Plone2.5.2/Python2.4.4/bin/python setup.py install

tar xzvf ZMySQLDA-2.0.8.tar.gz
cp -r ZMySQLDA /opt/Plone-2.5.2/zeocluster/Products/

Restart zope. But nothing install in the Products?

then I change to Products/ZMySQLDA directory try to import DA, it has the
following error?

$ /opt/Plone-2.5.2/Python-2.4.4/bin/python
Python 2.4.4 (#1, Mar  5 2007, 20:29:49)
[GCC 3.4.6 20060404 (Red Hat 3.4.6-3)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
import sys,string
import DA
Traceback (most recent call last):
File "<stdin>", line 1, in ?
File "/opt/Plone-2.5.2/zeocluster/client1/Products/ZMySQLDA/DA.py", line
155, in ?
  misc_={'conn': ImageFile(
line 74, in __init__
  self.fp = open(fp, "rb")
IOError: [Errno 2] No such file or directory:

the file DBAdapterFolder_icon.gif is actually in

Any suggestion?

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to