Maybe I just need a hit with a cluebat here.  But I just downloaded
the new Zope 2.9.7 tar ball (thanks Andreas and others who worked on
that!).  When I try bin/runzope or bin/zopectl fg or debug everything
looks fine.  But bin/zopectl start does nothing.

Has anyone else seen this?

I did the usual dance of ./configure, make, (sudo) make install.  The
configure options were:

./configure --with-python=/usr/bin/python --prefix=/opt/zope/zope2.9.7

Then I made a zope instance in ~/instances/t

Then start the zope instance:

~/instances/t $ bin/zopectl start
. daemon process started, pid=15466

Then nothing seems to happen.  No log file is being made:

~/instances/t $ tail -f /home/maurits/instances/t/log/event.log
tail: cannot open `/home/maurits/instances/t/log/event.log' for reading: No 
such file or directory
tail: no files remaining

There is one process running:

$ pgrep -lf zope
15465 /usr/bin/python /opt/zope/zope2.9.7/lib/python/zdaemon/zdrun.py -S 
/opt/zope/zope2.9.7/lib/python/Zope2/Startup/zopeschema.xml -b 10 -d -s 
/home/maurits/instances/t/var/zopectlsock -x 0,2 -z /home/maurits/instances/t 

and after a while that stops.

bin/zopectl fg meanwhile starts up zope just fine.

An alternative is to run 'make inplace' and 'make instance'  instead
of 'make install'.

Okay, so I removed the instance, unpacked a clean tar ball and did
configure, make, make inplace, make instance.  Again, bin/zopectl
start does not work, and foreground works fine.

I also just downloaded 2.8.9.  Let's first check if that might have
the same problem.  Ah, it at least has another problem:

$ /opt/zope/zope2.8.9/bin/mkzopeinstance.py 
[Errno 13] Permission denied: './README.txt'

and indeed:

$ ls -l /opt/zope/zope2.8.9/skel/README.txt 
-rw------- 1 root root 481 2007-03-25 11:33 /opt/zope/zope2.8.9/skel/README.txt

Ah, and when fixing this with a chmod some more errors like that creep up.

So after installing 2.8.9 as root or with sudo, mkzopeinstance does
not work.  This has happened to me with other Zope versions as well.
At least I remember reporting this earlier; and seeing it solved
fortunately. :)  It would seem the root source has not been
found/fixed though. :(

Any chance of fixing this?  Need any help Andrea?

Maurits van Rees | http://maurits.vanrees.org/ [NL]
            Work | http://zestsoftware.nl/
"Do not worry about your difficulties in computers,
 I can assure you mine are still greater."

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to