On 5/12/07, Mike Patterson <[EMAIL PROTECTED]> wrote:
    We've been experiencing two KeyError problems with Zope since moving
to a ZEO environment at the beginning of the year.  On the server that
the ZEO server resides we have 3 Zope instances running, and each of
them gets a KeyError about once or twice a week individually.
Restarting the offending instance takes care of the issue, but I was
wondering if anyone has an idea of why we would be seeing these.


The error that we get is:

2007-05-02T19:18:45 ERROR ZODB.Connection Couldn't load state for 0x1c2d6e
Traceback (most recent call last):
  File "/opt/Plone-2.5/lib/python/ZODB/Connection.py", line 732, in setstate
  File "/opt/Plone-2.5/lib/python/ZODB/Connection.py", line 768, in
    p, serial = self._storage.load(obj._p_oid, self._version)
  File "/opt/Plone-2.5/lib/python/ZEO/ClientStorage.py", line 746, in load
    return self.loadEx(oid, version)[:2]
  File "/opt/Plone-2.5/lib/python/ZEO/ClientStorage.py", line 774, in loadEx
    self._cache.store(oid, ver, tid, None, data)
  File "/opt/Plone-2.5/lib/python/ZEO/cache.py", line 293, in store
  File "/opt/Plone-2.5/lib/python/ZEO/cache.py", line 980, in add
    available = self._makeroom(size)
  File "/opt/Plone-2.5/lib/python/ZEO/cache.py", line 915, in _makeroom
    size, e = self.filemap.pop(ofs)
KeyError: 19826745

looks like there may be problems with the cache file.  try not using
the cache file and see whether that helps by removing name zeostrorage
on each clients.

http://myzope.kedai.com.my - my-zope org
Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to