Hello,

Please allow me to ask this question again, because
there is still an unsolved mystery.

> --On 25. Mai 2007 01:26:32 -0700 Ken Ara
> <[EMAIL PROTECTED]> wrote:
> 
> > We have a filesystem product with an edit method
> that
> > allows users to change some properties. At the
> end,
> > the user is redirected to the page from which they
> > came.
> >
> > Our setup has Squid in front on port 80, with
> Pound on
> > port 81 load-balancing to 3 ZEO clients.
> >
> > No matter how we define the redirect URL - even
> when
> > we hardcoded it explicitly with ':80' for test
> > purposes - the redirection is always to port 81.
> What
> > is going on?
> >

For us, virtual hosting is limited to two lines in the
VHM 'mappings' tab:

oursite.org/oursite
*oursite.org/oursite

Way back when VHM was new I tried skipping the part
about 'VirtualHostBase'. The instructions under
'About' were a bit cryptic: the statement, "VHM
doesn't do anything unless it sees one of the
following special path elements in a URL:
VirtualHostBase sets the protocol and host, while
VirtualHostRoot sets the path root" seemed inaccurate
- for me, everything just worked. All I had to do was
override the <baseref> tag and avoid the use of
absolute_url (or just remove ':81'). But I digress.

The weird thing is, before moving to our present
server, we had Squid on port 80 and Zope on port 81
with the same VHM setup (same ZODB). We never had any
problem with redirection.

So I doubt this VHM aspect really plays a role in our
problem. Actually, Pound is the only new element apart
from the change from Zope 2.7 to 2.10.

As a workaround, would there be something I could add
when calling RESPONSE.redirect to force the redirect
to port 80?

Thanks again
Ken


       
____________________________________________________________________________________You
 snooze, you lose. Get messages ASAP with AutoCheck
in the all-new Yahoo! Mail Beta.
http://advision.webevents.yahoo.com/mailbeta/newmail_html.html
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to