On 6/15/07, Maciej Wisniowski <[EMAIL PROTECTED]> wrote:


>   File "/opt/Zope-2.10/lib/python/Zope2/Startup/__init__.py", line
> 234, in dropPrivileges
>     return dropPrivileges(self.cfg)
>   File "/opt/Zope-2.10/lib/python/Zope2/Startup/__init__.py", line
> 403, in dropPrivileges
>     raise ZConfig.ConfigurationError(msg)
> ZConfig.ConfigurationError: A user was not specified to setuid to; fix
> this to start as root (change the effective-user directive in zope.conf)
> /** END **/
You have answer above. To run as root you have
to change effective-user at zope.conf file


I tried to change effective-user from the zope.conf.in file and saved it as
zope.conf, I used the command

effective-user tleis , as stated in the example of that file, but no thing
changed. if anyone knows why please tell me (just curousity)



>
> When everything was ok in the past I was able to run zope through
> ./zopectl start (as a root)
> but now the stop command displays that  the daemon manager is not open.
Strange that it worked. In general I think you shouldn't
run zope as root.

--
Maciej Wisniowski


I created a new user as Maciej said, and there i tried to create an
instance, but I got a denied permission message. What I did finally is that
I deleted the folders in both /tmp/zope and /opt/Zope-2.10 folders, and
installed Zope Again and everything is working fine right
now! but i still want to understand why this happened to me?
Thanks for you
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to