I'm trying to get a startup item set up under OS X Server 10.4 on an Intel XServe box. I'd like not to have to manually restart Zope every time a software update forces me to restart the machine. I've gotten the following written up, but it failed to run for some unspecified reason.

Here's the plist:

  Description     = "Zope Application Server";
  Provides        = ("Application Server");
  Uses            = ("Disks", "NFS");

And the startup script:


# Zope Application Server

. /etc/rc.common

ZOPE_APP_BASE=/path/to/zope/instances; export ZOPE_APP_BASE

StartService ()
    ConsoleMessage "Starting Zope Application Server"
    ${ZOPE_APP_BASE}/mysite1/zopectl start
    ${ZOPE_APP_BASE}/mysite2/zopectl start

StopService ()
    ConsoleMessage "Stopping Zope Application Server"
    ${ZOPE_APP_BASE}/mysite1/zopectl stop
    ${ZOPE_APP_BASE}/mysite2/zopectl stop

RestartService ()
    ConsoleMessage "Stopping Zope Application Server"
    ${ZOPE_APP_BASE}/mysite1/zopectl restart
    ${ZOPE_APP_BASE}/mysite2/zopectl restart

I have multiple zope instances running, and need to start them all, and this is my attempt, but it doesn't work.

Anyone out there have a successful StartupItem script that I could model mine after? Alternatively, anyone have any debugging experience on StartupItems and could point me at how to figure out more than 'it failed' (which is all the system log tells me)?

thanks in advance for any advice you all might have!


Cris Ewing
CME and Telehealth Web Services
Department of Radiology Web Services
University of Washington
School of Medicine
Work Phone: (206) 685-9116
Home Phone: (206) 365-3413

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to