-----Original Message-----
From: Dieter Maurer <[EMAIL PROTECTED]>
Cc: zope@zope.org
Sent: Sun, 22 Jul 2007 1:51 pm
Subject: Re: [Zope] AttributeError: Can't Pin It Down!

[EMAIL PROTECTED] wrote at 2007-7-21 14:27 -0400:
> > ...
> >Error Type: AttributeError
> >Error Value: masterMarketItems
> >
> >
> >This error shows on a page but not in the error log!!
> Maybe, it comes from your error page (i.e. "standard_error_message").
> Then, you should see the entry in the error log that caused
> the error in the first place.

Nothing in the error log about that :(

> > ...
> >Module Products.PageTemplates.TALES, line 221, in evaluate
> >URL: /example.com/eng/test
> >Line 7, Column 0
> >Expression: <PythonExpr request.contact_us_form.header()>
> > ...
> >Module Products.PageTemplates.ZRPythonExpr, line 47, in __call__
> >__traceback_info__: request.contact_us_form.header() 
> >
> >Module Python expression "request.contact_us_form.header()", line 1, in 
> <expression> 
> >
> >Module ZPublisher.HTTPRequest, line 1223, in __getattr__ 
> You did it almost right. You forgot to include the
> "Error Type" and "Error Value" information.

Exception Type


Exception Value


> But, from what you have included, I guess that "request" does
> not have a "contact_us_form" attribute.
Can you explain? I have a Formulator form called "contact_us_form" and it's in 
the same folder, so there's no problem with inheritance.

> I am unfamiliar with "Formulator" -- but it seems strange to me
> that you expect "request" to contain complete forms.
Well, frankly, I built this site a long time ago before PTs were in vogue and 
it worked just fine using DTML. I changed it to PT for you to throw and capture 
this error ;)

Since this is happening with all applications and they worked just fine before 
I took the *zexp snapshots and loaded them into the new server, I was thinking 
this must come from something below the application level; namely, from a built 
of Zope itself. I thought maybe I built this from a FBSD port, but no, it's Z 
2.7.8 and I built it from source thus:

tar zxvf Zope-2.7.8-final.tgz 

cd Zope-2.7.8-final 

./configure --with-python=/usr/local/bin/python2.3 --prefix=/usr/local/zope/278 
&& make && make install 


Directory: /usr/local/zope/instance1 

cd /usr/local/zope/instance1 

vi etc/zope.conf 

effective-user tony 

chown tony var/ 

chown tony etc/ 

chown tony etc/* 

chown tony log/ 

chown tony log/*

This is fine, though, right? Also, I went to zope to find a copy of this 
tarball and couldn't! Every other tarball is on the list but 2.7.8!!
What's up with that??

AOL now offers free email to everyone.  Find out more about what's free from 
AOL at AOL.com.
Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to