Hash: SHA1

Tracy R Reed wrote:
> I originally sent this to the plone-users list but nobody replied and it
> seems to be more of a zope-level problem anyway:
> I am trying to upgrade my instance from Plone 2.5.2 to 3.0.3 and I am having
> trouble. Been trying to do this upgrade off and on for the last two weeks.
> I have tried many things but if I just follow the instructions in the
> UPGRADE.txt file I am told to install the new plone, copy my Data.fs into
> it, start the instance, and then run the portal migration. So I do all of
> that and get <broken weblog> because I did not have my products
> (specifically Quills) installed in the new instance and the quills blog is
> my main page. So I shut down the instance, copied in Quills and its
> dependencies, started the instance, and went to view my site. This is what
> I saw:
> http://www.pastebin.ca/778070
> I notice that the first thing in that mess of an error page says "No
> traversable adapter found". I googled for this and found:
> http://groups.google.com/group/plone-users/browse_thread/thread/3ccc6e55db22ed70/2871c23a3401c671
> I downloaded my Plone 3.0.3 from plone.org in the form of the Unified
> Installer. It installed my plone, zope, python, etc. I checked and setup
> tools are included. So that shouldn't be the problem in my case.
> Then I found this:
> http://www.nabble.com/Buildout-problem-t4650763s20094.html
> So I started zope in the foreground and encountered this error:
> http://www.pastebin.ca/778107
> Which seems to ultimately say that it couldn't find
> /opt/Plone-3.0.3/lib/python/zope/app/annotation/configure.zcml
> And sure enough it doesn't exist. I'm not sure where to go from here. I
> have tried this install many different times in many ways on two different
> machines (CentOS 5 and Fedora 6) and haven't had much success.
> Any tips on how to resolve this would be greatly appreciated!

Quills needs to be updated to be compatible with Zope 2.10.x, which does
not have a 'configure.zcml' in the zope.app.annotation pacakge.  There
is a 1.6 beta release which is supposed to work with Plone 3.0.x / Zope


- --
Tres Seaver          +1 540-429-0999          [EMAIL PROTECTED]
Palladion Software   "Excellence by Design"    http://palladion.com
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to