I'm in the middle of trying to upgrade a Product written for Zope 2.7 so that it runs on Zope 2.10!

The product appears in the newer ZMI's list of available products but whenever I try to add an object of the products type through the ZMI I get the following error in the event.log and nothing is added to the site:

Traceback (innermost last):
  Module ZPublisher.Publish, line 125, in publish
  Module Zope2.App.startup, line 238, in commit
  Module transaction._manager, line 96, in commit
  Module transaction._transaction, line 395, in commit
  Module transaction._transaction, line 495, in _commitResources
  Module ZODB.Connection, line 502, in commit
  Module ZODB.Connection, line 1046, in savepoint
  Module ZODB.Connection, line 555, in _commit
  Module ZODB.Connection, line 582, in _store_objects
  Module ZODB.serialize, line 407, in serialize
TypeError: Can't pickle objects in acquisition wrappers.

additionally, if I take a Data.fs from my Zope 2.7 instance and try running with it in place on a 2.10 instance the various objects of the product already created simply don't show up (no broken icon, nothing)

Running Zope 2.10.5 and Python 2.4.4 and the Product in question was written using CMF 1.4.2 (but now upgraded to CMF 1.6.4, I've made several changes already to accomodate this upgrade)

I'd be grateful for any insight anyone might have or any hints at what to do next!

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to