On Mon, Mar 31, 2008 at 09:41:11AM -0400, Craig Chasseur wrote:
> Hello All,
> We've recently completed an upgrade to Zope 2.10.5 on one of our servers and 
> we've begun to encounter problems with ZSyncer. We use ZSyncer to synchronize 
> objects between this server and another running Zope 2.9.8 (both have ZSyncer 
> 0.7.1 installed). When attempting to "put" folders from the 2.10 server to 
> the 2.9 server, the process hangs and nothing is transferred. However, when 
> we attempt to put individual objects, we are successful.
> Does anyone know what might be the cause of this issue? ZSyncer 0.7.1, which 
> is the latest release, claims that it may not be compatible with Zope 2.9 and 
> up, but we were able to use it successfully before this most recent upgrade 
> to 2.10. If anyone is aware of a fix or a workaround, or simply has an 
> insight into why this breaks for us, I would greatly appreciate the help.

I've never tried ZSyncer with Zope 2.10; I don't have any guesses what
your problem is.

Have you tried syncing between two 2.10 instances? In general, you
move data from 2.X to 2.X-1 at your own risk, whether using ZSyncer or
the import/export tab in the ZMI.

I've been the "official" ZSyncer maintainer for about 5 years now, but
honestly I've barely touched it since 2005, since in its current state
it works well enough on the rare occasions that I need it. If somebody
else cares enough about ZSyncer to maintain it, please contact me.

Otherwise, to be crassly honest, I'm unlikely to do any
ZSyncer-related work unless somebody pays me to do so.


Paul Winkler
Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to