I upgraded to Zope 2.7.2 and all of my content can't be seen by Zope. Honestly I'm not sure what the previous version I was running was (nor am I sure how to find out).

Now, every page results in

Site Error
An error was encountered while publishing this resource.
Resource not found
Sorry, the requested resource does not exist.
Check the URL and try again.
Resource: Zope GET

There is effectively no more web interface. I've verified that the database still seems to be there in [instance]/var/Data.fs and hasn't been touched since the update. I tried going through some of the steps in the Troubleshooting and Debugging page http://www.zope.org/Documentation/Books/ZDG/current/TestingAndDebugging.stx

I can do a ZPublisher.Zope('/manage') in python and see that it returns a "Resource not found" page.

Interestingly, my log which was being written to /var/log/zope started writing to the default location after the install.

I feel like there isn't enough here to determine whether there is a bug or whether I've mucked something up myself. But perhaps some gentle guidance would help me determine whether there is a bug or just my own ignorance.

Was there a config file that got overwritten in the update? Where would it be?

Perhaps there are some clues in the lines written to the log file upon startup.


Old log file:

2008-04-10T14:43:08 INFO(0) ZServer HTTP server started at Thu Apr 10 14:43:08 2008
       Hostname: library.ucsc.edu
       Port: 8080
------
2008-04-10T14:43:08 INFO(0) ZServer FTP server started at Thu Apr 10 14:43:08 2008
       Hostname: library.ucsc.edu
       Port: 8021
------
2008-04-10T14:43:08 INFO(0) Zope Set effective user to "zope"
------
2008-04-10T14:43:12 PROBLEM(100) Init Ambiguous name for method of Products.ZpdfDocument.ZpdfDocument.ZpdfDoc
ument: "manage" != "manage_main"
------
2008-04-10T14:43:12 PROBLEM(100) Init Ambiguous name for method of Products.ZpdfDocument.ZpdfDocument.ZpdfDoc
ument: "manage" != "manage_editForm"
------
2008-04-10T14:43:12 PROBLEM(100) Init Ambiguous name for method of Products.ZpdfDocument.ZpdfDocument.ZpdfDoc
ument: "manage" != "manage_editDocument"
------
2008-04-10T14:43:14 INFO(0) ZODB Opening database for mounting: '146584832_1040950278.401039'
------
2008-04-10T14:43:14 INFO(0) ZODB Mounted database '146584832_1040950278.401039' at /temp_folder
------
2008-04-10T14:43:14 INFO(0) Zope Ready to handle requests


New log file:


2008-04-10T16:45:20 INFO ZServer HTTP server started at Thu Apr 10 16:45:20 2008
       Hostname: 0.0.0.0
       Port: 8080
------
2008-04-10T16:45:20 WARNING Init Class Products.HappySession.HappySession.HappySess
ion has a security declaration for nonexistent method 'manage_menu'
------
2008-04-10T16:45:21 WARNING Init Ambiguous name for method of Products.ZpdfDocument
.ZpdfDocument.ZpdfDocument: 'manage' != 'manage_main'
------
2008-04-10T16:45:21 WARNING Init Ambiguous name for method of Products.ZpdfDocument
.ZpdfDocument.ZpdfDocument: 'manage' != 'manage_editDocument'
------
2008-04-10T16:45:21 WARNING Init Ambiguous name for method of Products.ZpdfDocument
.ZpdfDocument.ZpdfDocument: 'manage' != 'manage_editForm'
------
2008-04-10T16:45:22 INFO Zope Ready to handle requests



W.



---
Wes Modes
McHenry Library
Computing & Network Services
Information and Technology Services
459-5208
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to