Dear all,

I just installed successfully zope2.11.0 on my mac.
I'm having a problem with importing some products. For instance ZMySQLDA (v. 2.0.8) gives me this error:


------
2008-06-21T12:37:30 ERROR Application Couldn't install ZMySQLDA
Traceback (most recent call last):
File "/Applications/zope211/lib/python/OFS/Application.py", line 758, in install_product
    global_dict, global_dict, silly)
File "/Applications/zope211/instance1/Products/ZMySQLDA/ __init__.py", line 91, in ?
    import DA
File "/Applications/zope211/instance1/Products/ZMySQLDA/DA.py", line 155, in ?
    misc_={'conn': ImageFile(
File "/usr/local/lib/python2.4/site-packages/PIL/ImageFile.py", line 74, in __init__
    self.fp = open(fp, "rb")
IOError: [Errno 2] No such file or directory: 'Shared/DC/ZRDB/www/ DBAdapterFolder_icon.gif'
------

After a google search I found this: http://dev.x3ng.com.br/browser/ Recria/buildout/patches/zmysqlda-imagefile.patch?rev=2386&format=txt

It looks like the problem is related to PIL and after applying the patch (-from ImageFile import ImageFile +from Globals import ImageFile) everything works just fine.

The question is: why this problem doesn't happen with zope2.10.5? I have the same setup... same python, same PIL. Applying the patch to the products doesn't look like a good school.
Do you have any suggestion?

Your help is much appreciated,

Giampiero



_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to