> Wolfgang Lausenhammer wrote:
> > 
> > LockError: Couldn't lock 
> > 'D:\\workspace_zope\\xla-2008/var/Stdcontainer_o.fs.lock'
> Can the user the zope process is running as write to this file?
> (or create it, since it likely doesn't exist?)

The file is existing. I tried to delete all the .index, .lock, .tmp files 
in the var-folder and zope re-creates them on calling the /manage site, so 
there shouldn't be a problem with writing-permissions

> > TypeError: not all arguments converted during string formatting
> > Traceback (most recent call last):
> >   File "D:\zope\2.11.1\Python\Lib\logging\__init__.py", line 731, in 
> >   File "D:\zope\2.11.1\Python\Lib\logging\__init__.py", line 617, in 
> >   File "D:\zope\2.11.1\Python\Lib\logging\__init__.py", line 405, in 
> > 
> >   File "D:\zope\2.11.1\Python\Lib\logging\__init__.py", line 276, in 
> > getMessage
> >     self.cfg.eventlog()
> This looks like a bug. Would be good to find where the incorrect logging 

> call is and fix it :-S

With the old 2.7.4 version it does work. I also tried to upgrade it in 
steps, with zope-2.8.6 it still works and none of those two error messages 
appear. With zope-2.9.8 at least one of these errors appeared. Has there 
anything changed in the interface within those versions?

The changelog of 2.9.0 says: "Zope now utilizes ZODB 3.6. It had 
previously used ZODB 3.4. As a result, the DBTab package was removed, as 
ZODB 3.6 has multidatabase support that makes DBTab unnecessary."
Could this cause those errors?

-- Wolfgang
Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to