I think I've worked out what is happening.  I'm assuming that the index_html
is written in ZPT; when edited TTW via the ZMI the "expand macros when
editing" is checked, so I guess the various TAL features are being removed
(hence it works until it is saved, and after that the dynamic parts are
missing).  I've no idea if there is a way to switch off this expansion by
default.  If there is, I would suggest that Zope is initially installed in
that condition.  As it is currently, I would say the tutorial examples are
quite confusing.  A real newbie would have little idea as to how it could be
that the HTML was being constructed.  I at least have been lurking round
Zope for some time, so I think I've been able to work it out.

On Sat, Dec 6, 2008 at 7:56 AM, Bernard Devlin <[EMAIL PROTECTED]> wrote:

> Hi, I'm looking at the idea of using Zope again (a lot seems to have
> changed..)  I'm using Zope 2.11.1, and whilst trying to remind myself of the
> basic machinery of Zope, I  imported the Example apps, and started to fiddle
> around with the Guestbook example.   However, after saving the index_html
> object of the Guestbook, Zope would no longer find any entries to display.
> To check it was simply the act of saving index_html that broke the
> Guestbook, I deleted the Examples folder and re-imported it.  With a fresh
> Examples folder Guestbook worked; simply saving it (without even typing in
> the textarea) would break the Guestbook.  On initial import it shows a
> single Guestbook entry by "Amos", but after saving index_html, it reports
> that the Guestbook is empty.  No changes were made to the 'getEntries'
> script, and the Entries folder still has the entry by "Amos".
> I can't see any reason why that would be, and hoped someone else could
> explain what the problem is.
Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to