HI,

I've encounters a performance Problem with Zope. Some requests take very
long time to process while others are served very fast. All request go for
the URL. The time for the delayed Requests grows with the memory size of
the Zope Process. It's direct proportional.

I have generated a chart showing the request times and memory size of the
Zope Process. The chart can be found at http://etustar.ze.tum.de/frontend.jpg

Our watchdog system restarts the Zope Process when it reaches 7.3 Gig
Memory. The physical memory of the server is 16 Gig and its only used for
the zope Server. There are at least 7 Gig Memory free.

As you can see most of the requests are delivered within 2 seconds but some
take up to 12 seconds. The Requests monitored are the request of our
watchdog system. These requests are send approximately every 20 sec.

When I set the restart memory limit higher the request time of the delayed
request continues to grows proportionally.

This server is part of a pool of 19 Servers. All are connected to one ZEO
server. All show the same effect.

We observe the same effect with regular requests. Some are served at normal
speed but some requests are delayed.

Any idea what causes this effect and how to fix it.

Greetings
        Gerhard Schmidt
-- 
-------------------------------------------------
Gerhard Schmidt       | E-Mail: schm...@ze.tum.de
TU-M√ľnchen            |
WWW & Online Services |
Tel: 089/289-25270    |
Fax: 089/289-25257    | PGP-Publickey auf Anfrage


Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to