Jürgen Herrmann wrote:
> the version of zopdb shipped with zope 2.10.5 is 3.7.1, so why
> does the command above try to pull an alpha release of zodb?
> can in "pin" the version of zodb to 3.7.1?

Zope includes ZODB.  You need a buildout that does not try to replace 
the version of ZODB that comes with Zope.  Furthermore, the version of 
ZODB that comes with Zope must be patched to support RelStorage.  Newer 
Zope releases will solve this problem, but Zope 2.10 users are stuck 
with this.

If you are installing Plone, you should follow the instructions here:


Those instructions make use of a handy "fake eggs" mechanism provided by 
the Plone recipe.  The fake eggs solution seems like the best way to use 
Buildout with Zope releases before 2.12.


Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to