On 16.05.09 17:54, Velayudhan, Vimalkumar wrote:
> Dear all,
> We had our original website setup on Zope-2.7.0-b2/Python-2.3.2. The
> website had to be moved to a different server. In order to keep the
> setup as similar as possible, Zope 2.8.7 was used with Python 2.3.4.
> There were some issues recently due to which Zope cannot open a
> connection to a gadfly database and reports it as corrupt with 'bad
> marshal data' error in the logs. I found this to be a Python problem
> rather than Zope as the same thing happens when trying to connect the
> database using Python 2.3.4. The database however, can be opened with
> newer versions of Python > 2.4.
> The same error had occurred before in the logs but never caused much
> downtime. 
> Hence we are considering using a newer version of Python for our
> website. 
>   
Consider migrating your app from Gadfly to a *real* database e.g. SQLite,
Postgres or MySQL. Gadfly is basically nothing one would use in
a production environment.


> Python 2.4 is supported from Zope 2.9.1 onwards. My question is should I
> use 2.9 or use the more recent stable version 2.11.3? Will there be any
> advantages/disadvantages?
see above

-aj
begin:vcard
fn:Andreas Jung
n:Jung;Andreas
org:ZOPYX Ltd. & Co. KG
adr;quoted-printable:;;Charlottenstr. 37/1;T=C3=BCbingen;;72070;Germany
email;internet:i...@zopyx.com
title:CEO
tel;work:+49-7071-793376
tel;fax:+49-7071-7936840
tel;home:+49-7071-793257
x-mozilla-html:FALSE
url:www.zopyx.com
version:2.1
end:vcard

_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to