On 18.05.09 21:21, Joseph Thomas (s) wrote:
>
> We upgraded from zope 2.9 to 2.10 and in the process upgraded plone as
> well.  There’s script that simply returns a list of groups to which a
> user belongs. In the old system both users in the system and not in
> the system (ie ids not in zope) would get HTTP 200 when invoking the
> script thru a URL (obviously the non-system users would get an empty
> list)..
>
>  
>
> Now when system users invoke the script the script returns the list of
> groups to which they belong, however, when a user not in the system
> invokes the script it returns a 401. Is there some
> authentication/security setting that we’re missing that’s preventing
> non-system users invoking the script? We may have overlooked some
> small thing (file system permissions, ZMI permissions, authentication
> settings etc) when configuring things in the upgraded environment….any
> ideas would help.
>
Google "Plone how to debug unauthorized"

-aj
begin:vcard
fn:Andreas Jung
n:Jung;Andreas
org:ZOPYX Ltd. & Co. KG
adr;quoted-printable:;;Charlottenstr. 37/1;T=C3=BCbingen;;72070;Germany
email;internet:i...@zopyx.com
title:CEO
tel;work:+49-7071-793376
tel;fax:+49-7071-7936840
tel;home:+49-7071-793257
x-mozilla-html:FALSE
url:www.zopyx.com
version:2.1
end:vcard

_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to