smita kamdar wrote:

> Hi,
> I am supposed to set up development environment for a project. & for that I
> have already installed Zope-2.11.4, Python-2.4.4, Egenix-2.0.6,
> Postgresql-7.4.13, & Psycopg-1.1.6 on a RedHat LINUX box.
> Now I need to install OpenFlow-1.1.0 in the Products directory of Zope. I
> tried installing OpenFlow source tar ball by the following instructions ?
> ./configure
> Make
> Sudo make install
> All of the above commands worked successfully. But still I am not able to
> see the openflow product on the Zope Management Interface Screen. Can you
> please suggest something? It?s really urgent. Am I missing any steps while
> installing OpenFlow? Please Help me.
> Regards,
> Smita

First of all you need to make a correct installation of Zope: use 'make inplace'
followed by './bin/'. 
In the created zope instance switch to the Products folder and unpack the
OpenFlow tgz file. 

The problem is: the code is old and not working with the last zope versions. The
fix is simple: in the file change line
 from Products.PageTemplates.Expressions import getEngine, _SecureModuleImporter
 from Products.PageTemplates.Expressions import getEngine, SecureModuleImporter

and remove
  SecureModuleImporter = _SecureModuleImporter()

(at least in the version I have)

If you need a workflow engine modern and up-to-date I counsel to integrate
openwfe (now 'route':
Riccardo Lemmi

Zope maillist  -
**   No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to