Hi all,

when trying to move from Zope 2.10 to 2.13, I ran into a problem. I successfully stripped versions out of my Data.fs (thanks to this mailing list). Now Zope starts up properly and displays the manage page, but when I try to access the various folders of the site, I get the error below.


Any ideas about how to overcome this?

Thanks, Frank


   Zope Error

Zope has encountered an error while publishing this resource.

*Error Type: TypeError*
*Error Value: (', use Persistence.Persistent.__new__()', , ())*

Traceback (innermost last):

 * Module ZPublisher.Publish, line 126, in publish
 * Module ZPublisher.mapply, line 77, in mapply
 * Module ZPublisher.Publish, line 46, in call_object
 * Module Shared.DC.Scripts.Bindings, line 322, in __call__
 * Module Shared.DC.Scripts.Bindings, line 359, in _bindAndExec
 * Module App.special_dtml, line 185, in _exec
 * Module DocumentTemplate.DT_Let, line 77, in render
 * Module DocumentTemplate.DT_In, line 647, in renderwob
 * Module DocumentTemplate.DT_In, line 772, in sort_sequence
 * Module ZODB.Connection, line 860, in setstate
 * Module ZODB.Connection, line 914, in _setstate
 * Module ZODB.serialize, line 612, in setGhostState
 * Module ZODB.serialize, line 605, in getState
 * Module ZODB.broken, line 106, in __new__

TypeError: ('object.__new__(Args) is not safe, use Persistence.Persistent.__new__()', <class 'Shared.DC.ZRDB.Aqueduct.Args'>, ())


_______________________________________________
Zope maillist  -  Zope@zope.org
https://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to