Hello,

many times now I tried to start zope, but I always get the following error:

mapr@AtomN270 /opt/TESTInstance/bin $ ./runzope
Traceback (most recent call last):
 File "/opt/bin/runzope", line 8, in <module>
   load_entry_point('Zope2==2.13.15', 'console_scripts', 'runzope')()
File "/opt/lib/python2.7/site-packages/Zope2-2.13.15-py2.7.egg/Zope2/Startup/run.py", line 22, in run
   starter.prepare()
File "/opt/lib/python2.7/site-packages/Zope2-2.13.15-py2.7.egg/Zope2/Startup/__init__.py", line 86, in prepare
   self.startZope()
File "/opt/lib/python2.7/site-packages/Zope2-2.13.15-py2.7.egg/Zope2/Startup/__init__.py", line 259, in startZope
   Zope2.startup()
File "/opt/lib/python2.7/site-packages/Zope2-2.13.15-py2.7.egg/Zope2/__init__.py", line 46, in startup
   from Zope2.App.startup import startup as _startup
File "/opt/lib/python2.7/site-packages/Zope2-2.13.15-py2.7.egg/Zope2/App/startup.py", line 38, in <module>
   import OFS.Application
File "/opt/lib/python2.7/site-packages/Zope2-2.13.15-py2.7.egg/OFS/Application.py", line 22, in <module>
   import App.Product
File "/opt/lib/python2.7/site-packages/Zope2-2.13.15-py2.7.egg/App/Product.py", line 44, in <module>
   from OFS.Folder import Folder
File "/opt/lib/python2.7/site-packages/Zope2-2.13.15-py2.7.egg/OFS/Folder.py", line 24, in <module>
   from webdav.Collection import Collection
File "/opt/lib/python2.7/site-packages/Zope2-2.13.15-py2.7.egg/webdav/Collection.py", line 30, in <module>
   from webdav.Resource import Resource
File "/opt/lib/python2.7/site-packages/Zope2-2.13.15-py2.7.egg/webdav/Resource.py", line 35, in <module>
   from OFS.event import ObjectClonedEvent
File "/opt/lib/python2.7/site-packages/Zope2-2.13.15-py2.7.egg/OFS/event.py", line 20, in <module>
   import OFS.interfaces
File "/opt/lib/python2.7/site-packages/Zope2-2.13.15-py2.7.egg/OFS/interfaces.py", line 19, in <module>
   from zope.location.interface import IPossibleSite
ImportError: No module named interface

log/event.log shows:
------
2012-09-10T21:59:59 INFO ZServer HTTP server started at Mon Sep 10 21:59:59 2012
       Hostname: 0.0.0.0
       Port: 8080

and var/zope.conf:

%define INSTANCE /opt/TESTInstance

instancehome $INSTANCE

effective-user mapr

<eventlog>
 level info
 <logfile>
   path $INSTANCE/log/event.log
   level info
 </logfile>
</eventlog>

<logger access>
 level WARN
 <logfile>
   path $INSTANCE/log/Z2.log
   format %(message)s
 </logfile>
</logger>

<http-server>
 address 8080
</http-server>

<zodb_db main>
   <filestorage>
     path $INSTANCE/var/Data.fs
   </filestorage>
   mount-point /
</zodb_db>

<zodb_db temporary>
   <temporarystorage>
     name temporary storage for sessioning
   </temporarystorage>
   mount-point /temp_folder
   container-class Products.TemporaryFolder.TemporaryContainer
</zodb_db>

Z2.log is empty ...

Any ideas? Thanks in advance,

Mario
_______________________________________________
Zope maillist  -  Zope@zope.org
https://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists -
https://mail.zope.org/mailman/listinfo/zope-announce
https://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to