I am trying to bring up-to-date an existing Zope set up running on an obsolete version of Zope. I am trying to get WebServerAuth to work for me as it seems to be the obvious replacement for the home-grown system in place on the exiting server.

So far, I have been unable to make it appear in the Products list.

I changed my buildout.cfg and the Product now appears in the eggs folder of my Zope installation, but not in the ZMI Control Panel

I found (and set) in zope.conf:  enable-product-installation on
So I know that a number of other products are bring installed.

I tried adding a suitable link in the Instance Products directory.
That resulted in "module not found" errors leading me to install additional Products (PluggableAuthService and CMFCore) and to link those in to the Products directory too.

I have now reached impasse with  CMFCore complaining:

   from zope.globalrequest import getRequest
      ImportError: No module named globalrequest

I have found and installed (with buildout) the zope.globalrequest egg, but I can't work out how to bodge any links to make things work.


Can anyone tell me how to install this Product ?
(All this is being done with  Zope2-2.13.18 )

Shane Voss, Computing Officer, School of GeoSciences, University of Edinburgh

The University of Edinburgh is a charitable body, registered in
Scotland, with registration number SC005336.

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists -
https://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to