Hello once more,

I’m running a fresh Zope2 ZEO setup (pip install 
--index-url=http://download.zope.org/Zope2/index/2.13.22/ Zope2 and pip install 
zope.mkzeoinstance) inside a virtualenv setup.

As said: No products, fresh setup, happens with any object. Going to any undo 
tab produces this error: Error Type: DisconnectedError

Client log:

2015-05-06 01:16:46 INFO ZEO.ClientStorage zeostorage Disconnected from 
storage: "('localhost', 9999)"
2015-05-06 01:16:46 ERROR Zope.SiteErrorLog 1430867806.070.275579780745
Traceback (innermost last):
  Module ZPublisher.Publish, line 138, in publish
  Module ZPublisher.mapply, line 77, in mapply
  Module ZPublisher.Publish, line 48, in call_object
  Module Shared.DC.Scripts.Bindings, line 322, in __call__
  Module Shared.DC.Scripts.Bindings, line 359, in _bindAndExec
  Module App.special_dtml, line 185, in _exec
  Module App.Undo, line 112, in undoable_transactions
  Module ZODB.DB, line 901, in undoInfo
  Module ZEO.ClientStorage, line 1283, in undoInfo
  Module ZEO.ServerStub, line 285, in undoInfo
  Module ZEO.zrpc.connection, line 776, in call
  Module ZEO.zrpc.connection, line 796, in wait
2015-05-06 01:16:46 WARNING ZEO.zrpc (19205) CW: error connecting to ('::1', 
2015-05-06 01:16:46 INFO ZEO.ClientStorage zeostorage Testing connection 
<ManagedClientConnection ('', 9999)>
2015-05-06 01:16:46 INFO ZEO.zrpc.Connection('C') ( received 
handshake ‚Z3101'

ZEO server log:

2015-05-06T01:15:13 INFO ZEO.zrpc.Connection('S') ( received 
handshake 'Z3101'
2015-05-06T01:16:46 ERROR ZEO.zrpc (19082) can't decode message: 
2015-05-06T01:16:46 ERROR ZEO.zrpc.Connection('S') ( Error 
caught in asyncore
Traceback (most recent call last):
  File "/opt/python/2.7.9/lib/python2.7/asyncore.py", line 83, in read
  File "/opt/python/2.7.9/lib/python2.7/asyncore.py", line 449, in 
  File "/opt/python/zope2-latest/lib/python2.7/site-packages/ZEO/zrpc/smac.py", 
line 240, in handle_read
line 417, in message_input
    msgid, async, name, args = self.decode(message)
line 80, in server_decode
    return unpickler.load() # msgid, flags, name, args
line 120, in server_find_global
    raise ZRPCError("import error %s: %s" % (module, msg))
ZRPCError: import error copy_reg:
2015-05-06T01:16:46 INFO ZEO.StorageServer ( disconnected

The path difference in /opt/python/2.7.9/lib/python2.7/asyncore.py vs 
/opt/python/zope2-latest/lib/python2.7/site-packages make me wonder if this is 
a bug or a problem with my setup?

Client + ZEO server were created from the same virtualenv.

Python 2.7.9 build from source.

Any ideas?

Best, Sebastian

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists -
 https://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to