Yamana,

did you try to login with the recovery user/password?

To do so you have to create an emerceny user using the zpasswd.py script 
(locatet either at site-packages/Zope2/Startup/misc/zpasswd.py or 
site-packages/Zope2/utilities/zpasswd.py I Zope was installed from egg.

Example in command line/terminal on our systems (virtualenv used):

cd —path to your zope instance --
/opt/python/zope2-pip/lib/python2.7/site-packages/Zope2/utilities/zpasswd.py -u 
<user> -p <password> access

This creates an access file in the bin folder. Move this file to the root of 
the instance:

cd bin
mv access ..

Now restart Zope and you should be able to login using the new credentials.
Correct what you broke then ;-)

Best
Sebastian

> Am 27.06.2015 um 10:56 schrieb Yamana santhosh kumar 
> <y.santhosh32ku...@gmail.com>:
> 
> Hello to all zope users.......
> 
>      I have been facing a problem with authentication in zope, i.e when i try 
> to access the zope with localhost:8080/manage it is showing that the username 
> and password , it is shown below.....
> <image.png>
> even though i am giving correct username and password, it is showing that you 
> are not autherised person to access this resource ......(note:i have changed 
> some check boxes in authentications in acl_users folder)
> 
> I hope that any body can help me to this issue....
> 
> Thanks in advance.....
> 
> 
> 
> 
> _______________________________________________
> Zope maillist  -  Zope@zope.org
> https://mail.zope.org/mailman/listinfo/zope
> **   No cross posts or HTML encoding!  **
> (Related lists -
> https://mail.zope.org/mailman/listinfo/zope-announce
> https://mail.zope.org/mailman/listinfo/zope-dev )


_______________________________________________
Zope maillist  -  Zope@zope.org
https://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists -
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to