A new issue has been submitted to the **Issue tracker**
tracker by **Jesse Snyder** and awaits confirmation.

Issue Information
-----------------

Issue
  Latest plone2.5_buildout recipe requires at least PasteScript 1.7.2 
(http://plone.org/products/zopeskel/issues/42)


**Issue Details**::

    Running against PasteScript 1.3.6, there's a mismatch between the
    method signature for paste.script.command.challenge and the way
    it's called by the plone2.5_buildout interactive session:



    Traceback (most recent call last):

      File "/usr/local/bin/paster", line 7, in ?

        sys.exit(

      File "/usr/local/lib/python2.4/site-
    packages/PasteScript-1.3.6-py2.4.egg/paste/script/command.py",
    line 78, in run

        invoke(command, command_name, options, args[1:])

      File "/usr/local/lib/python2.4/site-
    packages/PasteScript-1.3.6-py2.4.egg/paste/script/command.py",
    line 117, in invoke

        exit_code = runner.run(args)

      File "/usr/local/lib/python2.4/site-
    packages/PasteScript-1.3.6-py2.4.egg/paste/script/command.py",
    line 212, in run

        result = self.command()

      File "/usr/local/lib/python2.4/site-packages/PasteScript-1.3.6-p
    y2.4.egg/paste/script/create_distro.py", line 121, in command

        vars = template.check_vars(vars, self)

      File "/usr/local/lib/python2.4/site-
    packages/ZopeSkel-2.16-py2.4.egg/zopeskel/base.py", line 317, in
    check_vars

        response = cmd.challenge(prompt, var.default, var.should_echo)

    TypeError: challenge() takes at most 3 arguments (4 given)



    The ZopeSkel version needs to declare a newer PasteScript as a
    dependency.


* This is an automated email, please do not reply - plone.org Administrator
_______________________________________________
ZopeSkel mailing list
ZopeSkel@lists.plone.org
http://lists.plone.org/mailman/listinfo/zopeskel

Reply via email to