Review: Needs Fixing

It looks like you didn't fix the indentation of calls to init_val() in 
zorbacmdproperties_base.h, and in fact it looks like you moved a number of 
other instances of calls to that method onto the ends of earlier lines of code 
in zorba_properties.h. It's just not good readability. To be clear, I'm talking 
about lines like this:

   if (*argv == NULL) { result = "No value given for --classpath option"; 
break; }        init_val (*argv, theClasspath, d);

There's no reason to have that call to init_val() hanging out over there. I 
count 9 places where this is done, most of which were put that way with this 
change.


You also didn't rename the class "IStream". Rodolfo reported that that class 
name conflicted with a Windows class, making the code not compile on Windows. 
It's not clear to me if this is one of the changes for "optimizing XQJ" you 
mentioned, but if it actually causes a compilation failure it must be changed.
-- 
https://code.launchpad.net/~zorba-coders/zorba/module-schema-tools/+merge/97978
Your team Zorba Coders is subscribed to branch lp:zorba.

-- 
Mailing list: https://launchpad.net/~zorba-coders
Post to     : zorba-coders@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zorba-coders
More help   : https://help.launchpad.net/ListHelp

Reply via email to