** Changed in: zorba
   Importance: High => Medium

-- 
You received this bug notification because you are a member of Zorba
Coders, which is the registrant for Zorba.
https://bugs.launchpad.net/bugs/867222

Title:
  Introduce ABI compatibility check

Status in Zorba - The XQuery Processor:
  New

Bug description:
  Going forward in 2.x releases, we need to ensure backwards
  compatibility at both the source and binary levels. There are certain
  API changes that would be backwards-compatible if clients recompiled
  their code, but would not allow simply re-linking against a later
  release; we need to avoid those changes.

  One possibility would be an "ABI checker" as part of the remote queue
  run; I seem to recall seeing such software, somewhere...

To manage notifications about this bug go to:
https://bugs.launchpad.net/zorba/+bug/867222/+subscriptions

-- 
Mailing list: https://launchpad.net/~zorba-coders
Post to     : zorba-coders@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zorba-coders
More help   : https://help.launchpad.net/ListHelp

Reply via email to