Review: Approve The change looks good.
Only 2 general comments: 1) func_sequences_impl.cpp It seems wasteful to first codegen the underlying probe iterators and then to re-create them here. It would be nice to parameterize the codeine on the way down - but I guess that there's no easy way of doing that … 2) index_dll.h/.cpp There is a lot of redundancy in the ProbeIndex Iterators. This is obviously independent of this merge proposal, but this merge proposal makes it very clear. -- https://code.launchpad.net/~zorba-coders/zorba/opt-count-index-probe/+merge/105528 Your team Zorba Coders is subscribed to branch lp:zorba. -- Mailing list: https://launchpad.net/~zorba-coders Post to : firstname.lastname@example.org Unsubscribe : https://launchpad.net/~zorba-coders More help : https://help.launchpad.net/ListHelp