Hello Chris, 
Unfortunately, telling you to close the bug was a bad idea. This morning, I 
found an additional issue. When compiling zorba or sausalito on a clean ubuntu 
12.04, I get this:
-- --- Module:   util-jvm    ---
-- Looking for JNI
-- Looking for Java
-- Building Zorba without util-jvm module.
-- ---

The reason why I didn't catch this on the ubuntu machine I am working on is the 
following:
On my machine:
ls /usr/lib/jvm/
default-java  java-1.5.0-gcj-4.6  java-1.6.0-openjdk  java-1.6.0-openjdk-amd64  
java-6-openjdk  java-6-openjdk-amd64  java-6-openjdk-common  
java-7-openjdk-amd64

On clean machine:
ls /usr/lib/jvm/
java-1.6.0-openjdk-amd64  java-6-openjdk-amd64  java-6-openjdk-common  
java-7-openjdk-amd64

I do not know where this difference comes from. I assume because my
ubuntu was upgraded from 10.04 to 12.04. Because we want to ship
sausalito as soon as possible, I am fixing this issue directly in
sausalito instead of waiting for a new merge. But the fixes I did can be
applied to zorba too:

0)
FindJNI.cmake is used in the util-jvm module only. But it is 4 times in the 
zorba repositories. Therefore, I removed the following files and directories:
zorba/cmake_modules/FindJNI.cmake
zorba_modules/data-formatting/cmake_modules
zorba_modules/schema-tools/cmake_modules

1)
The custom FindJNI.cmake in the util-jvm module is not used. Therefore, I did 
the following change:
=== modified file 'runtime/zorba_modules/util-jvm/CMakeLists.txt'
--- runtime/zorba_modules/util-jvm/CMakeLists.txt       2012-05-22 09:45:57 
+0000
+++ runtime/zorba_modules/util-jvm/CMakeLists.txt       2012-06-13 08:26:13 
+0000
@@ -19,6 +19,7 @@
 IF (ZORBA_SUPPRESS_JAVA)
   MESSAGE (STATUS "ZORBA_SUPPRESS_JAVA is true - not searching for Java")
 ELSE (ZORBA_SUPPRESS_JAVA)
+  SET (CMAKE_MODULE_PATH ${PROJECT_SOURCE_DIR}/cmake_modules 
${CMAKE_MODULE_PATH})
 
   MESSAGE(STATUS "")
   MESSAGE(STATUS "--- Module:   util-jvm    ---")

2)
I extended the FindJNI.cmake in the util-jvm to find the files on clean ubuntu 
12.04. I attached the patch.


I think this patches should go into the zorba 2.5 release. Otherwise, java 
modules do not work. What do you think?


** Patch added: "findjni.diff"
   
https://bugs.launchpad.net/zorba/+bug/989490/+attachment/3187503/+files/findjni.diff

** Changed in: zorba
       Status: Invalid => Incomplete

-- 
You received this bug notification because you are a member of Zorba
Coders, which is the registrant for Zorba.
https://bugs.launchpad.net/bugs/989490

Title:
  on ubuntu 12.04, Java and/or JNI not found

Status in Zorba - The XQuery Processor:
  Incomplete

Bug description:
  Hey Chris

  Java and/or JNI is not found on ubuntu 12.04. Therefore, fop doesn't
  work. I think the paths to java stuff changed on ubuntu 12.04. Maybe,
  cmake 2.8.8 is handle those changes. cmake 2.8.7 is not.

  David

To manage notifications about this bug go to:
https://bugs.launchpad.net/zorba/+bug/989490/+subscriptions

-- 
Mailing list: https://launchpad.net/~zorba-coders
Post to     : zorba-coders@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zorba-coders
More help   : https://help.launchpad.net/ListHelp

Reply via email to