Chris Hillery has proposed merging lp:~zorba-coders/zorba/bug-1015964 into 
lp:zorba.

Requested reviews:
  Chris Hillery (ceejatec)
Related bugs:
  Bug #1015964 in Zorba: "Add warning re: SWIG 2.0.7 for PHP binding"
  https://bugs.launchpad.net/zorba/+bug/1015964

For more details, see:
https://code.launchpad.net/~zorba-coders/zorba/bug-1015964/+merge/125137
-- 
https://code.launchpad.net/~zorba-coders/zorba/bug-1015964/+merge/125137
Your team Zorba Coders is subscribed to branch lp:zorba.
=== modified file 'doc/zorba/build_prerequisites.dox'
--- doc/zorba/build_prerequisites.dox	2012-09-17 00:36:37 +0000
+++ doc/zorba/build_prerequisites.dox	2012-09-19 09:17:25 +0000
@@ -95,6 +95,19 @@
 at least Swig 1.3.40 or later (http://www.swig.org/download.html).
 All bindings are generated using Swig.
 
+\note There is a known bug in many versions of Swig
+  (http://sourceforge.net/tracker/index.php?func=detail&aid=3479190&group_id=1645&atid=101645)
+  that affects a small number of platforms, including at least
+  FreeBSD. If you get compilation errors that look similar to this:
+
+\code
+   build/swig/php/zorba_apiPHP5_wrap.cxx:953: error: invalid conversion from 'const char*' to 'char*'
+\endcode
+
+  then you may have run into this bug. Our experience is that Swig
+  version at least 2.0.7 has corrected this bug, so please try upgrading
+  to that version.
+
 For a particular language binding, you need the corresponding language
 tools and development headers. CMake will automatically enable the
 language bindings for any language that is detected.

-- 
Mailing list: https://launchpad.net/~zorba-coders
Post to     : zorba-coders@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zorba-coders
More help   : https://help.launchpad.net/ListHelp

Reply via email to