Review: Needs Information

Sorin,

If I read the dependencies correctly in my Ubuntu install, libfop-java depends 
on libxalan2-java package that includes serializer.jar:

dpkg -s libfop-java
Package: libfop-java
Status: install ok installed
Priority: optional
Section: java
Installed-Size: 9529
Maintainer: Ubuntu Developers <ubuntu-devel-disc...@lists.ubuntu.com>
Architecture: all
Source: fop
Version: 1:1.0.dfsg2-6
Replaces: fop (<< 1:1.0.dfsg2-6)
Depends: libxerces2-java, libxalan2-java, libbsf-java, libavalon-framework-java 
(>= 4.1.2-2), libbatik-java (>= 1.7), libcommons-io-java, 
libcommons-logging-java, libxt6, libxtst6, libxmlgraphics-commons-java (>= 
1.4), java-wrappers (>= 0.1.15), libxml-commons-external-java


dpkg -L libxalan2-java | grep .jar/usr/share/java/xalan2-2.7.1.jar
/usr/share/java/serializer-2.7.1.jar
/usr/share/java/xalan2.jar
/usr/share/java/serializer.jar
/usr/share/maven-repo/xalan/xalan/2.7.1/xalan-2.7.1.jar
/usr/share/maven-repo/xalan/xalan/debian/xalan-debian.jar
/usr/share/maven-repo/xalan/serializer/2.7.1/serializer-2.7.1.jar
/usr/share/maven-repo/xalan/serializer/debian/serializer-debian.jar

Also if you check the fop binary distribution: 
http://www.us.apache.org/dist/xmlgraphics/fop/binaries/fop-1.0-bin.tar.gz it 
contains serializer.jar.

I don't want to remove the dependency check, unless clearly proved that it's 
not a dependency, especially when there aren't any tests for fop module.

-- 
https://code.launchpad.net/~zorba-coders/zorba/fix_dependency/+merge/144307
Your team Zorba Coders is subscribed to branch lp:zorba/data-formatting-module.

-- 
Mailing list: https://launchpad.net/~zorba-coders
Post to     : zorba-coders@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zorba-coders
More help   : https://help.launchpad.net/ListHelp

Reply via email to