Matthias Brantner has proposed merging 
lp:~zorba-coders/zorba/bug-improve-ser-error into lp:zorba.

Commit message:
improve error message for invalid serialization version parameter

Requested reviews:
  Matthias Brantner (matthias-brantner)
  Chris Hillery (ceejatec)

For more details, see:
https://code.launchpad.net/~zorba-coders/zorba/bug-improve-ser-error/+merge/176821

let $params :=
  <serialization-parameters 
xmlns="http://www.w3.org/2010/xslt-xquery-serialization";>                       
                                                                          
    <version value="1.4"/>
    <method value="xml"/>
  </serialization-parameters>
return                                                                          
                                                                                
                      
  fn:serialize(<a/>, $params)

was changed from reporting

error [err:SESU0013]: "16": unsupported XML version; supported versions are: 
"1.0", "1.1";

to

error [err:SESU0013]: "1.4": unsupported XML version; supported versions are: 
"1.0", "1.1";
-- 
https://code.launchpad.net/~zorba-coders/zorba/bug-improve-ser-error/+merge/176821
Your team Zorba Coders is subscribed to branch lp:zorba.
=== modified file 'src/api/serialization/serializer.cpp'
--- src/api/serialization/serializer.cpp	2013-07-11 14:04:33 +0000
+++ src/api/serialization/serializer.cpp	2013-07-24 22:45:34 +0000
@@ -2560,7 +2560,7 @@
     {
       if (version != PARAMETER_VALUE_VERSION_1_0 && version != PARAMETER_VALUE_VERSION_1_1)
         throw XQUERY_EXCEPTION(
-          err::SESU0013, ERROR_PARAMS( version, "XML", "\"1.0\", \"1.1\"" )
+          err::SESU0013, ERROR_PARAMS( version_string, "XML", "\"1.0\", \"1.1\"" )
         );
     }
 

-- 
Mailing list: https://launchpad.net/~zorba-coders
Post to     : zorba-coders@lists.launchpad.net
Unsubscribe : https://launchpad.net/~zorba-coders
More help   : https://help.launchpad.net/ListHelp

Reply via email to