following problem occurs on my SLES 11.1, kernel 2.6.32.12-0.7-default,
zypper 1.3.7:

I get all packages to update:

# zypper lu
Loading repository data...
Reading installed packages...
S | Repository          | Name               | Current Version   | Available 
Version | Arch  
--+---------------------+--------------------+-------------------+-------------------+-------
v | epages.com - update | epages-j           | 6.14.2-0          | 6.15.0-0     
     | i386  
v | epages.com - update | epages-patch       | 6.14.2-0          | 6.15.0-0     
     | i386  
v | epages.com - arch   | jdk                | 2000:1.7.0_05-fcs | 
2000:1.7.0_09-fcs | x86_64
v | epages.com - arch   | mongo-10gen        | 2.0.6-mongodb_1   | 
2.2.1-mongodb_1   | x86_64
v | epages.com - arch   | mongo-10gen-server | 2.0.6-mongodb_1   | 
2.2.1-mongodb_1   | x86_64

updating all packages works:

# zypper up
Loading repository data...
Reading installed packages...

The following package updates will NOT be installed:
  

The following NEW package is going to be installed:
  epages-patch_6_15_0 

The following packages are going to be upgraded:
  epages-j epages-patch jdk mongo-10gen mongo-10gen-server 

The following packages are not supported by their vendor:
  epages-j epages-patch epages-patch_6_15_0 jdk mongo-10gen mongo-10gen-server 

5 packages to upgrade, 1 new.
Overall download size: 406.3 MiB. After the operation, additional 442.3 MiB 
will be used.
Continue? [y/n/?] (y): n

But I can't update only selected packages:

# zypper up 'epages-*'
Loading repository data...
Reading installed packages...
No update candidate for 'epages-appsrv'.
No update candidate for 'epages-common'.
No update candidate for 'epages-mysql'.
No update candidate for 'epages-mysqld'.
No update candidate for 'epages-patch_6_14_2'.
No update candidate for 'epages-perl'.
No update candidate for 'epages-release'.
No update candidate for 'epages-reqsrv'.
Resolving package dependencies...

Nothing to do.

Nor that works:

# zypper up epages-j
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Nothing to do.

Do you have an idea how to update only selected packages?

Greetings, Wolf.
--
To unsubscribe, e-mail: zypp-devel+unsubscr...@opensuse.org
To contact the owner, e-mail: zypp-devel+ow...@opensuse.org

Reply via email to