Hi Michael,

I'm currently checking the rpm db. As far as I know, libsolv supports 32Bit IDs only. That should be okay, because we won't need that much IDs :-)

But for any reason, our IDs within our rpmdb are much higher... (there is no small number anywhere, really strange :-))

So it does not seem to be a libsolv problem at all, sorry for that!

The rpm version is with berkeley db 4.8.30.

Now I'll recreate the rpm db and will track which tool causes this behavior.

Thank you,

On 03/05/13 14:42, Michael Schroeder wrote:

Hi Tony,

On Thu, May 02, 2013 at 04:21:45PM +0200, Tony Wolf wrote:
So, rpm sees all installed packages; but the @System/solv files seems to
be broken.

We use the following versions:
   * zypper 1.8.9 (+ bugfix of swig BoolSave)
   * libzypp 13.1.0
   * libsolv latest snapshot from git/origin
   * boost 1.53.0

Do you have a hint, where I may take a look at, to solve the problem?

What version of rpm do you use?


To unsubscribe, e-mail: zypp-devel+unsubscr...@opensuse.org
To contact the owner, e-mail: zypp-devel+ow...@opensuse.org

Reply via email to