On 06/06/13 15:46, Michael Schroeder wrote:
> On Thu, Jun 06, 2013 at 03:26:11PM +0200, Sebastian Schubert wrote:
>> I want to install the package flac2all:
>> https://build.opensuse.org/package/show?package=flac2all&project=home%3Asebschub
>> which is only available in this very repository (my obs home
>> repository). I thus added the home repository to my local list of
>> repositories (see below for list of activated repositories).
>> Installing from the repository does not take into account the
>> recommended and suggested packages:
>> # zypper in flac2all
>> [...]
>> # zypper in /home/schubert/Downloads/flac2all-3.28-2.1.noarch.rpm
>> [...]
>> The following package is recommended, but will not be installed because
>> it's unwanted (was manually removed before):
>>   vorbis-tools
>> [...]
>> I would expect the very same behaviour. Is this a bug or a feature?
> Looks like a bug to me. As I don't see anything in your flac packages
> that recommends vorbis-tools, it looks like the "zypper in flac2all"
> run is actually correct. The zypper.log probably contains some hints
> about what's going on.

In line 26--28 of the flac2all.spec file, it is written

Recommends:     vorbis-tools
Suggests:       lame
Suggests:       nero-aac

so the vorbis-tools are in fact recommended, are they not? So the output of
zypper in /home/schubert/Downloads/flac2all-3.28-2.1.noarch.rpm
is what I would expect.

Anyway, I'll post a bug report.


Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to