Joerg Wunsch wrote:

As Matthew MacClary wrote:

(About whether to keep <avr/interrupt.h> or <avr/signal.h> after
merging their contents.)

   My suggestion would be to change INTERRUPT to be the same as
SIGNAL, and then deprecate SIGNAL.
How about changing the name to "ISR," which would do the same thing as the existing "SIGNAL"?


#include <avr/isr.h>

ISR( SIG_ADC ) {
   // interrupt service routine code here
}


Then, SIGNAL and INTERRUPT can both be deprecated (avoiding future confusion).



            --  Zane




_______________________________________________
AVR-GCC-list mailing list
AVR-GCC-list@nongnu.org
http://lists.nongnu.org/mailman/listinfo/avr-gcc-list

Reply via email to