This function was renamed in this commit in mainline linux:
commit f06c7f9f92295faf701a9628b383156c4efb6119
Author: dingtianhong <dingtianh...@huawei.com>
Date:   Fri May 9 14:58:05 2014 +0800

    vlan: rename __vlan_find_dev_deep() to __vlan_find_dev_deep_rcu()

Signed-off-by: Hauke Mehrtens <ha...@hauke-m.de>
---
 backport/backport-include/linux/if_vlan.h | 4 ++++
 1 file changed, 4 insertions(+)

diff --git a/backport/backport-include/linux/if_vlan.h 
b/backport/backport-include/linux/if_vlan.h
index 6fae150..7d39d52 100644
--- a/backport/backport-include/linux/if_vlan.h
+++ b/backport/backport-include/linux/if_vlan.h
@@ -20,4 +20,8 @@
 #define VLAN_PRIO_SHIFT                13
 #endif
 
+#if LINUX_VERSION_CODE < KERNEL_VERSION(3,16,0)
+#define __vlan_find_dev_deep_rcu(real_dev, vlan_proto, vlan_id) 
__vlan_find_dev_deep(real_dev, vlan_proto, vlan_id)
+#endif
+
 #endif /* __BACKPORT_LINUX_IF_VLAN_H_ */
-- 
1.9.1

--
To unsubscribe from this list: send the line "unsubscribe backports" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to