Ralf Wildenhues <[EMAIL PROTECTED]> writes:

> Hi Simon,
>
> * Simon Josefsson wrote on Mon, Jan 30, 2006 at 10:40:56AM CET:
>> 
>> I wonder what the best idiom for gnulib should be.  We probably do not
>> want to require automake CVS just yet.  Should it be the one I'm using:
>> 
>> TESTS += test-gc$(EXEEXT)
>> check_PROGRAMS += test-gc
>> 
>> or should we do
>> 
>> selftests = test-gc$(EXEEXT)
>> TESTS += $(selftests)
>> check_PROGRAMS += $(selftests)
>> 
>> Opinions?
>
> Just that, iff you decide to go for the latter, pretty please don't use
> a generic name like $(selftests) but a name that makes it clear this is
> a gnulib variable, for example `gl_selftests'.  Otherwise the stacking-
> software-made-hard department will want gnulib to _not_ use
>   selftests = ..
> but
>   selftests += ..
> and require the gnulib user to initialize this variable.  Not nice.

Hi Ralf!  Yes, I agree.  When I think about it more, I think the best
solution now is:

gl_selftests = test-gc$(EXEEXT)
TESTS += $(gl_selftests)
check_PROGRAMS += $(gl_selftests)

This avoid duplicating the "test-gc" part, which I do currently.

I'll test this and suggest a patch.

Thanks.


_______________________________________________
bug-gnulib mailing list
bug-gnulib@gnu.org
http://lists.gnu.org/mailman/listinfo/bug-gnulib

Reply via email to